【POJ 3070】Fibonacci(矩阵快速幂)

Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions:18114   Accepted: 12587

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题意其实说的很清楚,斐波那契数列的第n项即为1 1的n次方的后的第一项,由于让输出后四位,即对10000取余即可,

                                                                         1 0

#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define MAXN 105
const int mod=10000;
struct mat
{
    ll m[MAXN][MAXN];
}unit;
ll n;
mat msub(mat a,mat b)
{
    mat ans;
    ll x=0;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            x=0;
            for(int k=0;k<2;k++)
            {
                x+=((a.m[i][k]*b.m[k][j])%mod);
            }
            ans.m[i][j]=x%mod;
        }
    }
    return ans;
}

mat qpow(mat a,ll x)
{
    mat ret=unit;
    while(x)
    {
        if(x&1) ret=msub(ret,a);
        a=msub(a,a);
        x>>=1;
    }
    return ret;
}
void init_unit()
{
    for(int i=0;i<MAXN;i++)
    {
        unit.m[i][i]=1;
    }
}
ll solve(ll n)
{
    init_unit();
    mat a;
    a.m[0][0]=1;
    a.m[0][1]=1;
    a.m[1][0]=1;
    a.m[1][1]=0;
    a=qpow(a,n);
    return a.m[0][1];
}
int main()
{
    while(cin>>n&&n!=-1)
    {
        cout<<solve(n)<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/80272123