PAT 甲级 1152 Google Recruitment (20分)(简单题,直接模拟)

1152 Google Recruitment (20分)
 

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819
 

Sample Output 1:

49877
 

Sample Input 2:

10 3
2468024680
 

Sample Output 2:

404

题意:给定n和k,n表示要输入的数据的长度,k表示在输入的数据中找出长度为k的素数(第一次出现),找到输出这个素数,如果没有输出404。

解题思路:直接模拟,在主函数外写一个判断是否是素数的函数,输入的数据很大,所以用字符串处理,素数的个位基本上是奇数,除了2,但题目说了可以有前导0,所以我们还要考虑个位是2的情况,在字符串找到奇数,然后往前去k个,组成一个字符串,将其转化成整数,然后调用素数判断函数,找到输出这个字符串,找不着就输出404。
————————————————
版权声明:本文为CSDN博主「水果妹妹踩前端的坑」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/Imagirl1/article/details/85330953

#include<bits/stdc++.h>
using namespace std;
char a[1005];
bool prime(int x){
    if(x<2) return false;
    if(x==2) return true;
    for(int i=2;i<sqrt(x);i++){
        if(x%i==0){
            return false;
        }
    }
    return true;
}
int main(){
    int n,k;
    cin>>n>>k;
    cin>>a;
    int l=strlen(a);
    int x=0;
    int f=0;
    for(int i=0;i<=l-k;i++){
        x=0;
        for(int j=i;j<=i+k-1;j++){
            x=x*10+a[j]-'0';
        }
        //cout<<x<<endl;
        if(prime(x)){
            for(int j=i;j<=i+k-1;j++){            
                cout<<a[j];
            }
            f=1;
            break;
        }
    }
    if(!f){
        cout<<"404";
    }
    return 0;
} 

猜你喜欢

转载自www.cnblogs.com/caiyishuai/p/13369378.html