【PAT】【贪心】月饼:给定所有种类月饼的库存量、总售价、以及市场的最大需求量,计算可以获得的最大收益是多少

https://pintia.cn/problem-sets/994805260223102976/problems/994805301562163200
月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50

#include <iostream>
#include<algorithm>
using namespace std;

struct moonCake {
    
    
	double numOwn;
	double nSinglePrice;
	double nPrice;
};
bool compare(moonCake& a, moonCake& b) {
    
    
	if (a.nSinglePrice > b.nSinglePrice)
	{
    
    
		return true;
	}
	else {
    
    
		return false;
	}
}

double GetMaxIncome(int nKind, moonCake* moons, double need) {
    
    
	sort(moons, moons + nKind, compare);
	int leftNeed = need;
	double income = 0;
	int index = 0;
	while (abs(leftNeed) > 1e-9 && index<nKind)
	{
    
    
		if (leftNeed - moons[index].numOwn >= -1e-9)
		{
    
    
			income += moons[index].nPrice;
			leftNeed -= moons[index].numOwn;
			index++;
		}
		else if (leftNeed - moons[index].numOwn < 1e-9) {
    
    
			income += leftNeed * moons[index].nSinglePrice;
			leftNeed = 0;
		}
	}
	return income;
}
int main()
{
    
    
	int nKind;
	double nMaxNeed;
	cin >> nKind >> nMaxNeed;
	moonCake* moons = new moonCake[nKind];
	for (int i = 0; i < nKind; i++)
	{
    
    
		cin >> moons[i].numOwn;
	}
	for (int i = 0; i < nKind; i++)
	{
    
    
		cin >> moons[i].nPrice;
		moons[i].nSinglePrice = moons[i].nPrice / moons[i].numOwn;
	}
	printf("%.2f\n", GetMaxIncome(nKind, moons, nMaxNeed)) ;
}


猜你喜欢

转载自blog.csdn.net/qinglingLS/article/details/124030547
今日推荐