POJ-3070 Fibonacci (矩阵快速幂)

POJ-3070 Fibonacci (矩阵快速幂)

Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
     

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source



这道题初始值是1,少了些步骤。简化了

  F(n)=f(n-1)+f(n-2)

  列矩阵的元素个数是由n-x的x决定的

#include<cstdio>
using namespace std;
int n,base[2][2],ans[2][2];
void mul(int b[2][2],int a[2][2],int tans[2][2])
{
     int i,j,k;
     int t[2][2];
     for(i=0;i<2;i++)
        for(j=0;j<2;j++)
        {
            t[i][j]=0;
            for(k=0;k<2;k++)
            t[i][j]=(t[i][j]+b[i][k]*a[k][j])%10000;    //在答案出取余就好
        }
     for(i=0;i<2;i++)
        for(j=0;j<2;j++)
           tans[i][j]=t[i][j];
 }
void pow_mod()    //base[][],ans[][],n定成全局变量了
{
        base[0][0]=base[0][1]=base[1][0]=1;base[1][1]=0;
        ans[0][0]=ans[1][1]=1;
        ans[1][0]=ans[0][1]=0;
        while(n)
        {
                if((n&1)==1)
                mul(base,ans,ans);
                mul(base,base,base);
                n>>=1;
        }
}
int main()
{
    while(scanf("%d",&n))
    {
        if(n==-1)
        break;
        pow_mod();
        printf("%d\n",ans[1][0]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/80533609
今日推荐