最短路 (floyd)算法

最短路算法之一:

floyd算法模版:

时间复杂度O(n^3)。

题目链接:    http://acm.hdu.edu.cn/showproblem.php?pid=1874 (水题)


Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
 
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
 
  
2 -1


     模版如下:

    

#include <iostream>
using namespace std;
const int maxn  = 210;
const int inf = 0xfffff;

int a[maxn][maxn];

int main () {
    ios::sync_with_stdio (false);
    int n, m;
    int d, b, c;
    while (cin >> n >> m ){
        for (int i = 0 ; i < n; i++){
            for (int j = 0; j < n ; j++) {
                if(i == j){
                    a[i][j] = 0;
                }
                else{
                    a[i][j] = inf;
                }
            }
        }
        for (int i = 1; i <= m; i++){
            cin >> d >> b >> c ;
            if (a[d][b] > c){
                a[d][b] = a[b][d] = c ;
            }
        }
        for (int i = 0; i < n; i++){
            for (int j = 0; j < n; j++){
                for (int k = 0; k < n; k++){
                    if (a[j][k] > a[j][i] + a[i][k]){
                        a[j][k] = a[j][i] + a[i][k];
                    }
                }
            }
        }
        int x, y;
        cin >> x >> y ;
        if (a[x][y] < inf) {
            cout << a[x][y] << endl ;
        }
        else {
            cout << -1 << endl ;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41190227/article/details/79439203