【PAT】A1067. Sort with Swap(0,*) (25)

Description:
Given any permutation of the numbers {0, 1, 2,…, N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:
Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, …, N-1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10 3 5 7 2 6 4 9 0 8 1


Sample Output:
9
//NKW 甲级真题1025
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int a1[maxn];
int main(){
	int n, left = 0, num;
	scanf("%d", &n);
	for (int i = 0; i < n; i++){
		scanf("%d", &num);
		a1[num] = i;			//num的位置为i
		if (num != i&&num != 0)
			left++;				//num非0,并且不在对应的位置上
	}
	int k = 1, cnt = 0;
	while (left > 0){
		if (a1[0] == 0){
			while (k < n){
				if (a1[k] != k){
					swap(a1[0], a1[k]);
					cnt++;
					break;
				}
				k++;		//很关键,
			}
		}
		while (a1[0] != 0){
			swap(a1[0], a1[a1[0]]);
			cnt++;
			left--;
		}
	}
	printf("%d\n", cnt);
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/80958332