hdu 1049

Climbing Worm

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21380    Accepted Submission(s): 14676


Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
 

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
 

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
 

Sample Input
 
  
10 2 1 20 3 1 0 0 0
 

Sample Output
 
  
17 19
题目注意:1.不满一分钟按一分钟算;
         2.当向上爬是恰好到达顶端,那么虫子直接就上去了,没有休息还下滑的情况发生;
#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cmath>
using namespace std;

typedef long long LL;

int main(){
    int n, u, d;
    while(scanf("%d", &n) != EOF && n){
            scanf("%d%d", &u, &d);
            int cnt = 0, h = 0;
            h = u;
            cnt++;
            while(h < n){
                h -= d;
                cnt++;
                h += u;
                cnt++;
            }
            cout << cnt << endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/guihaiyuan123/article/details/79966331
今日推荐