Is It A Tree?

题目:

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
扫描二维码关注公众号,回复: 2659554 查看本文章

题意:

 给出一堆边给你,让你判断这是不是一棵树。

思路:

只判断了是否成环即(点的数量=边的数量+1)就过了......

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int book[21];
int main()
{
    int a,b,t=1;
    while(scanf("%d%d",&a,&b)&&(a!=-1||b!=-1))
    {
        int maxx=-1;
        memset(book,0,sizeof(book));
        if(a==0&&b==0)
        {
            printf("Case %d ",t++);
            printf("is a tree.\n");
            continue;
        }
        maxx=max(maxx,a);
        maxx=max(maxx,b);
        int sum=1;
        book[a]=1;book[b]=1;
        while(scanf("%d%d",&a,&b)&&(a||b))
        {
            book[a]=1;book[b]=1;
            sum++;
            maxx=max(maxx,a);
            maxx=max(maxx,b);
        }
        int sum2=0;
        for(int i=1;i<=maxx;i++)
        {
            if(book[i]==1)
                sum2++;
        }
        printf("Case %d ",t++);
        if(sum+1==sum2)
            printf("is a tree.\n");
        else
            printf("is not a tree.\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/admin__/article/details/81544051