A - 单点更新板子题 *

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。 
这让很多学生很反感。 

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。 
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。 
学生ID编号分别从1编到N。 
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。 
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。 
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。 
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。 

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9


        
  

Hint

Huge input,the C function scanf() will work better than cin.

一道模板题,但是因为输入卡了半天,一直TLE,用%c的时候一定要在之前加上getchar(); 因为%c会吸收换行符(\n);

以后长记性,用%s.

#include<istream>
#include<stdio.h>
#include<cstring>
#include<cmath>
using namespace std;
#define ls o<<1
#define rs o<<1|1
const int M=2e5+10;
int a[M];
struct node{
	int l,r;
	int x;
}t[M<<2];
inline void push_up(int o){
	t[o].x=max(t[ls].x,t[rs].x);//max
}

void build(int l,int r,int o){
	t[o].l=l, t[o].r=r;
	if(l==r) { t[o].x=a[l]; return ;}	
	int mid=(l+r)>>1;
	build(l,mid,ls); build(mid+1,r,rs);
	push_up(o);
}

inline int query(int l,int r,int o){
	if(l<=t[o].l&&t[o].r<=r) return t[o].x;
	int mid=(t[o].l+t[o].r)>>1;
	if(r<=mid) return query(l,r,ls);
	else if(l>mid) return query(l,r,rs);
	else return max(query(l,mid,ls),query(mid+1,r,rs));
}
inline void update(int s,int o,int x){
	if(t[o].l==t[o].r&&t[o].l==s){
		t[o].x=x;	return ;
	}
	int mid=(t[o].l+t[o].r)>>1;
	if(s<=mid) update(s,ls,x);
	else update(s,rs,x);
	push_up(o);
}

int main()
{
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF){
		for(int i=1;i<=n;i++) scanf("%d",&a[i]);
		build(1,n,1);
		char c;
		int l,r,x;
		while(m--){
			getchar();//一定要加上这个,不然一直TLE 
			scanf("%c",&c);
			if(c=='Q'){
				scanf("%d %d",&l,&r);
				printf("%d\n",query(l,r,1));
			}
			else if(c=='U'){
				scanf("%d %d",&l,&x);
				update(l,1,x);
			}
		} 
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41555192/article/details/81915225