PAT (Advanced Level) Practice A1085 Perfect Sequence (25 分)(C++)(甲级)(排序,二分法)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86523242

1085 Perfect Sequence (25 分)
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤10​9​​ ) is the parameter. In the second line there are N positive integers, each is no greater than 10​9.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:

8

//B1030英文版
//https://blog.csdn.net/m0_37454852/article/details/86523186

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

long long int p, A[100010] = {0};//因为中间有乘积,可能会越界,改用long long存储
int N, i, pos, max_len = 0;

int first_over(int left, long long int temp)//二分法查找第一个大于p*A[i]的位置
{
    if(A[N-1] <= temp) return N;
    int l, r, mid;
    for(l=left, r=N-1; l<r; )
    {
        mid = l+(r-l)/2;
        if(A[mid] <= temp) l = mid+1;
        else r = mid;
    }
    return l;
}

int main()
{
    scanf("%d %lld", &N, &p);
    for(i=0; i<N; i++)scanf("%lld", &A[i]);
    sort(A, A+N);//sort两个参数默认升序排序
    for(i=0; i<N-max_len; i++)
    {
        pos = first_over(i+1, p*A[i]);//(或可用C++库函数)pos = upper_bound(A+i+1, A+N, p*A[i]) - A;
        max_len = max(max_len, pos-i);
    }
    printf("%d", max_len);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86523242