二.JSP开发过程中遇到的问题及解决

转载自:http://www.cnblogs.com/leftshine/p/5238001.html

一.开发环境问题

问题一:Failed to load the JNI shared library

启动Eclipse时弹出“Failed to load the JNI shared library……”这样的一段提示,如下图:

大概意思就是说在某个位置找不到 jvm.dll 这个文件

原因1: 指定目录下 jvm.dll 不存在,可能是安装过程中文件损坏了或者勿删了文件。

对策: (1)重新安装jre或者jdk并配置好环境变量。

    (2)copy一个jvm.dll放在该目录下。

原因2:  eclipse的版本与jre或者jdk版本不一致

对策:  要么两者都安装64位的,要么都安装32位的,不能一个是32位一个是64位。

原因2的概率更大一些,原因1不太可能发生

问题解决:

第一种原因的概率小且解决法简单,这里这只讲第二种原因的具体解决方案:

首先在命令行中输入java -version ,查看JDK是多少位,一般显示64位的就是64为JDK,未显示的一般为32位的JDK。下图中显示64位,说明博主是64位JDK。

然后,我们来确定eclipse是多少位的。我们打开eclipse的安装目录(绿色版的就是你解压后的目录),右击eclipse.ini文件以记事本的方式打开,如下图

查看--launcher.library下面的一行,如果显示的是win32.x86则表明eclipse是32位的,如果显示的win32.x86_64,则是64位的。从下图可知,这个eclipse是64位的,因为博主jdk版本也是64位的,所以JDK与eclipse兼容,没有出现Failed to load the JNI shared library这个问题。

如果通过以上方法查看到JDK与eclipse的位数不同,就需要重新安装其中一个软件使位数统一,你觉得换哪个方便就换哪个,或者你觉得32位和64位的哪个好就用哪个。

这里就会体现出用绿色版eclipse的好处了,如果你是用的绿色版eclipse,直接删掉换新的就行了!安装版稍微麻烦点需要卸载了再安装。

换JDK的换可能还需要配置一次环境变量。

换什么自己斟酌哈,eclipse和JDK的具体安装与配置可以参看博主 WEB系统及应用开发 系列的另外一篇文章:《一.JSP开发的工具下载与环境搭建

问题二:Failed to install Tomcat7 service

安装tomcat过程中出现:Failed to install Tomcat7 service Check your settings and permissions Ignore and continue anyway (not recommended)?  如下图:

上面问题应该是卸载tomcat时直接删除目录导致的。

问题解决:

首先停止安装程序,然后以管理员身份运行命令提示符(cmd),执行 sc delete Tomcat7 命令,显示删除成功后再重新安装tomcat。

 

右键“命令提示符”,选择“以管理员身份运行”

输入 sc delete Tomcat7 回车确认,显示删除成功即可。博主的tomcat并没有问题,就不演示回车了(没问题这样干,不是自杀吗……)

删除之后就可以重新安装tomcat了,祝顺利!

以上针对tomcat7, 其他版本方式类似(不要告诉我你不知道把tomcat7换成tomcat4、5、6、8、9……)

如果上诉方法不能解决问题,我们还有绝杀:下个绿色免安装版的,直接解压就可以用了(只是后期操作可能会麻烦些,如果只是用于JSP开发的话,配置好了,之后就基本不会有什么操作了)!

目前就遇到这些问题,有新的问题再来更新!

猜你喜欢

转载自www.cnblogs.com/cc2013/p/8926185.html

相关文章