Out of sort II [洛谷] (算法理解) /*rank*/

原题传送门


题面:

Out of sort II

                              time limit per test : 1 second
                           memory limit per test : 256 megabytes
                                   input : standard input
                                  output : standard output

Problem Description

Keeping an eye on long term career possibilities beyond the farm, Bessie the cow has started learning algorithms from various on-line coding websites.

Her favorite algorithm thus far is “bubble sort”. Here is Bessie’s initial implementation, in cow-code, for sorting an array A of length N.

sorted = false

while (not sorted):

sorted = true

moo

for i = 0 to N-2:

if A[i+1] < A[i]:

     swap A[i], A[i+1]

     sorted = false

Apparently, the “moo” command in cow-code does nothing more than print out “moo”. Strangely, Bessie seems to insist on including it at various points in her code.

After testing her code on several arrays, Bessie learns an interesting observation: while large elements can be pulled to the end of the array very quickly, it can take small elements a very long time to “bubble” to the front of the array (she suspects this is how the algorithm gets its name). In order to try and alleviate this problem, Bessie tries to modify her code so that it scans forward and then backward in each iteration of the main loop, so that both large and small elements have a chance to be pulled long distances in each iteration of the main loop. Her code now looks like this:
sorted = false

while (not sorted):

sorted = true

moo

for i = 0 to N-2:

  if A[i+1] < A[i]:

     swap A[i], A[i+1]

for i = N-2 downto 0:

  if A[i+1] < A[i]:

     swap A[i], A[i+1]

for i = 0 to N-2:

  if A[i+1] < A[i]

     sorted = false

Given an input array, please predict how many times “moo” will be printed by Bessie’s modified code.

Input

The first line of input contains N (1≤N≤100,000). The next N lines describe A[0]…A[N−1], each being an integer in the range 0…1e9. Input elements are not guaranteed to be distinct.

Output

Print the number of times “moo” is printed.

Sample Input

5
1
8
5
3
2

Sample Output

2

题意描述

一个双向冒泡排序,求对给定数组的swap的执行次数.

题目分析

一个正向排序是将一个原本在前面,排序后在后面的数往后移动.一个逆向排序是将一个原本在后面,排序后在前面的数往前移动.

思路可以正向也可以反向.

正向:若排序后当前数的原本位置位于当前位置的后面,说明该数是从后面来到当前位置.那么cnt+1,同时对当前数的原本位置打上访问标记,但是如果当前数的当前位置是已访问状态时,说明当前数是位于之前排序的数的前面,那么cnt-1(去除重复),然后moo = max(cnt , moo),再对下一个数进行同样处理.

反向:若排序后当前数的原本位置位于当前位置的前面,说明该数是从前面来到当前位置,那么cnt+1,同时对当前数的原本位置打上访问标记,但如果当前数的当前位置是已访问状态时,说明当前数是位于之前排序的数的后面,那么cnt-1(去重),然后moo = max(moo , cnt),接着对下一个数做同样处理.

具体代码

正向

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;

struct node
{
    int num , cnt;
};
node cow[maxn];

bool cmp(node A, node B)
{
    if(A.num != B.num) return A.num < B.num;
    return A.cnt < B.cnt;
}

bool vis[maxn];

int main()
{
    int N;
    cin >> N;
    for(int i = 1; i <= N; i++)
    {
        cin >> cow[i].num;
        cow[i].cnt = i;
    }
    sort(cow+1 , cow+1+N , cmp);
    int cnt = 0, ans = 1;
    for(int i = 1; i <= N; i++)
    {
        if(cow[i].cnt > i)
        {
            cnt++;
        }
        if(vis[i])
        {
            cnt--;
        }
        vis[cow[i].cnt] = true;
        ans = max(cnt , ans);
    }
    cout << ans << endl;
    return 0;
}

反向

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;

struct node
{
    int num , cnt;
};
node cow[maxn];

bool cmp(node A, node B)
{
    if(A.num != B.num) return A.num < B.num;
    return A.cnt < B.cnt;
}

bool vis[maxn];

int main()
{
    int N;
    cin >> N;
    for(int i = 1; i <= N; i++)
    {
        cin >> cow[i].num;
        cow[i].cnt = i;
    }
    sort(cow+1 , cow+1+N , cmp);
    int cnt = 0, ans = 1;
    for(int i = N; i >= 1; i--)
    {
        if(cow[i].cnt < i)
        {
            cnt++;
        }
        if(vis[i])
        {
            cnt--;
        }
        vis[cow[i].cnt] = true;
        ans = max(cnt , ans);
    }
    cout << ans << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43726593/article/details/88285068
今日推荐