Fibonacci POJ - 3070 (矩阵快速幂的模板)

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fnare all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


题意:就是求 Fibonacci 数列的第n项的数;

思路:矩阵快速幂,最重要的就是构造式子,

如:在斐波那契数列之中

fi[i] = 1*fi[i-1]+1*fi[i-2]

 fi[i-1] = 1*f[i-1] + 0*f[i-2];

所以

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
#define mod 10000
struct node
{
	ll a[2][2];
};
ll n;

node s_cheng(node tt,node kk)
{
	int i,j,k;
	node c;
	c.a[0][0] = c.a[0][1] = c.a[1][0] = c.a[1][1] = 0;
	for(i=0;i<2;i++)
		for(j = 0;j<2;j++)
			for(k = 0;k<2;k++)
				c.a[i][j] = (c.a[i][j] + tt.a[i][k] * kk.a[k][j])%mod; 
	return c;
}

node jz_pow(node tt,ll n)
{
	node res;
	res.a[0][0] = res.a[1][1] = 1;
	res.a[0][1] = res.a[1][0] = 0;
	while(n)
	{
		if(n&1) res = s_cheng(res,tt);
		n>>=1;
		tt = s_cheng(tt,tt);
	}
	return res;
}
int main()
{
	while(~scanf("%lld",&n)&&n!=-1)
	{
		if(n==0)
		{
			printf("0\n");
			continue;
		} 
		node tt,res;
		tt.a[0][0] = tt.a[0][1] = tt.a[1][0] = 1;
		tt.a[1][1] = 0;
		res.a[0][0] = 1;
		res.a[1][0] = 0;
		tt = jz_pow(tt,n-1);
		res = s_cheng(tt,res);
		printf("%lld\n",res.a[0][0]); 
	}
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/obsorb_knowledge/article/details/80329777