1086 Tree Traversals Again (25 分)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
此题告知对树的先序遍历的出入栈操作,实质上可以得出其先序序列即为入栈序列,而出栈序列即为中序序列。则此题即可转化为已知先序和中序序列,建树并遍历的过程。注意先序及中序序列的获取
参考代码如下:
#include <cstdio>
#include <stack>
#include <cstring>
#include <algorithm>
using namespace std;
struct node {
int data;
node* lchild;
node* rchild;
};
int pre[30],in[30];
int n;
node* create(int prel,int prer,int inl,int inr)
{
if(prel>prer)
return NULL;
node* root=new node;
root->data=pre[prel];
int k;
for(k=inl;in[k]!=pre[prel];++k)
;
int leftnum=k-inl;
root->lchild=create(prel+1,prel+leftnum,inl,k-1);
root->rchild=create(prel+leftnum+1,prer,k+1,inr);
return root;
}
int num=0;//已输出结点个数
void postorder(node* root)
{
if(root==NULL)
return ;
postorder(root->lchild);
postorder(root->rchild);
printf("%d",root->data);
num++;
if(num<n)
printf(" ");
}
int main()
{
scanf("%d",&n);
char str[5];
stack<int> s;
int x,preindex=0,inindex=0;//入栈元素,先序序列位置及中序序列位置
for(int i=0;i<2*n;++i)//出入栈共2n次
{
scanf("%s",str);
if(strcmp(str,"Push")==0) //入栈
{
scanf("%d",&x);
s.push(x);
pre[preindex++]=x; //更新先序序列
}
else{
int t=s.top();//否则为出栈,则更新中序序列
s.pop();
in[inindex++]=t;
}
}
node* root=create(0,n-1,0,n-1);
postorder(root);
printf("\n");
return 0;
}