PAT|1067. Sort with Swap(0,*)

Given any permutation of the numbers {0, 1, 2,…, N-1}, it is easy to
sort them in increasing order. But what if Swap(0, *) is the ONLY
operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3}
we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4)=> {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the
given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N
(<=105) followed by a permutation sequence of {0, 1, …, N-1}. All
the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need
to sort the given permutation.

Sample Input: 10 3 5 7 2 6 4 9 0 8 1 Sample Output: 9

并查集

#include<iostream>
#include<stdio.h>
#include<vector>
using namespace std;
vector<int>s;
int n;
int findRoot(int x)
{
    if (s[x] < 0)
        return x;
    else
        return findRoot(s[x]);
}
void Uion(int a,int b)
{
    int ra = findRoot(a);
    int rb = findRoot(b);
    if (ra != rb)
    {
        if (s[ra] <= s[rb])
        {
            s[ra] += s[rb];
            s[rb] = ra;
        }
        else
        {
            s[rb] += s[ra];
            s[ra] = rb;
        }
    }
}
int main()
{
    while (scanf("%d",&n)!=EOF)
    {
        s.clear();
        s.resize(n);
        for (int i = 0; i < n; i++)
        {
            s[i] = -1;
        }
        for (int i = 0; i < n; i++)
        {
            int emp;
            scanf("%d", &emp);
            Uion(i, emp);
        }
        int k = 0;
        int x = 0;
        for (int i = 0; i < n; i++)
        {
            if (s[i] < -1)
                k++;
            if (s[i] == -1)
                x++;
        }
        int count;
        if (s[0] != -1)
            count = (n - x) + k - 2;
        else
            count = (n - x) + k;
        printf("%d\n", count);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_35205772/article/details/52450741