UVA 1252 Twenty Questions (记忆化搜索+DP状压)*

 Consider a closed world and a set of features that are defined for all the objects in the world. Each feature can be answered with “yes” or “no”. Using those features, we can identify any object from the rest of the objects in the world. In other words, each object can be represented as a fixed-length sequence of booleans. Any object is different from other objects by at least one feature. You would like to identify an object from others. For this purpose, you can ask a series of questions to someone who knows what the object is. Every question you can ask is about one of the features. He/she immediately answers each question with “yes” or “no” correctly. You can choose the next question after you get the answer to the previous question. You kindly pay the answerer 100 yen as a tip for each question. Because you don’t have surplus money, it is necessary to minimize the number of questions in the worst case. You don’t know what is the correct answer, but fortunately know all the objects in the world. Therefore, you can plan an optimal strategy before you start questioning. The problem you have to solve is: given a set of boolean-encoded objects, minimize the maximum number of questions by which every object in the set is identifiable.
Input
The input is a sequence of multiple datasets. Each dataset begins with a line which consists of two integers, m and n: the number of features, and the number of objects, respectively. You can assume 0 < m ≤ 11 and 0 < n ≤ 128. It is followed by n lines, each of which corresponds to an object. Each line includes a binary string of length m which represent the value (“yes” or “no”) of features. There are no two identical objects. The end of the input is indicated by a line containing two zeros. There are at most 100 datasets.
Output
For each dataset, minimize the maximum number of questions by which every object is identifiable and output the result.
Sample Input
8 1 11010101 11 4 00111001100 01001101011 01010000011 01100110001 11 16 01000101111 01011000000 01011111001 01101101001 01110010111 01110100111 10000001010 10010001000 10010110100 10100010100 10101010110 10110100010 11001010011 11011001001 11111000111 11111011101 11 12 10000000000 01000000000 00100000000 00010000000 00001000000 00000100000 00000010000 00000001000 00000000100 00000000010 00000000001 00000000000 9 32 001000000 000100000 000010000 000001000 000000100 000000010 000000001 000000000 011000000 010100000 010010000 010001000 010000100 010000010 010000001 010000000 101000000 100100000 100010000 100001000 100000100 100000010 100000001 100000000 111000000 110100000 110010000 110001000 110000100 110000010 110000001 110000000 0 0
Sample Output
0 2 4 11 9

#include<bits/stdc++.h>
#define ms memset
#define maxn 5000
using namespace std;

#define debug puts("YES");
#define read(x,y) scanf("%d%d",&x,&y)
#define rep(x,y,z) for(int (x)=(y);(x)<(z);(x)++)
#define mod 1e9+7
#define ll unsigned long long

#define INF 10000

/*
题目大意:给定一个问题集合和特征集合,
问至多能进行几次询问来确定唯一的物体。

这道题思维还是蛮难的,个人认为不看紫书上的讲解蛮困难的。
首先在解决dp问题时始终要有一个问题:
状态如何坍塌,坍塌到最后是什么情况。

这题随着提问的次数增多,状态显然不是一维可以表示的了,
用二元组(s,w)集合来表示,s表示已经询问过的特征集合,
w表示已经确定的特征集合,这样预处理的cnt[s][w]意义就清楚了,
在问题集中拥有特征w的数量。

*/


int m,n;
char c[20];
int a[130];///状态的压缩
int cnt[maxn][maxn];///状态的计数,如果询问过特征集合s,拥有特征集w的个数用cnt[s][w]计数
int dp[maxn][maxn];

int Dp(int s,int w)///记忆化搜索
{
    if(dp[s][w]!=-1) return dp[s][w];
    if(cnt[s][w]<=1) return 0;

    int &ret=dp[s][w] , t ; ret=1000;
    rep(i,0,m) if( ( (1<<i) &s )==0)///已经问过的特征就没必要再问了
    {
        t=max(Dp( s|(1<<i) , w ) , Dp(s|(1<<i),w|(1<<i)) )+1;///题目的要求跟提问的顺序有关联的
        ret=min(ret,t);
    }
    return ret;
}

int main()
{
    ///freopen("in.txt","r",stdin);
    while(read(m,n)&&(n||m))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%s",c);  int sta=0;
            for(int i=m-1;i>=0;i--) sta=sta*2+(c[i]-'0');
            a[i]=sta;
        }

        memset(cnt,0,sizeof(cnt));
        rep(i,0,(1<<m))  rep(j,0,n) cnt[i][i&a[j]]++;

        memset(dp,-1,sizeof(dp));
        printf("%d\n",Dp(0,0));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/81662072