POJ1733 Parity game 【扩展域并查集】*

版权声明:欢迎转载,请注明出处,谢谢 https://blog.csdn.net/Dream_maker_yk/article/details/82228020

POJ1733 Parity game


Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend’s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either even or odd (the answer, i.e. the parity of the number of ones in the chosen subsequence, where even means an even number of ones and odd means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3


题意:
告诉你有一个长度为L的01串
然后告诉你n个询问和结果
询问一个区间中的1的个数是计数还是偶数
然后给出答案
问你前多少个答案是合法的


这题我有另一个做法的题解啊,在这里

然后这个做法好像是啥扩展域并查集

意思就是说我们把每个点的前缀奇和前缀偶分成两个点,然后每次我们可以发现一些点之间的等价关系(连边),只需要判断:
1. 是不是当前命题不成立
2. 是不是有一个点的奇数和偶数是等价的(连上边),然后并查集维护


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=10000;
#define OD(t) t
#define EV(t) t+MAXN
const int N=10010;
int fa[N<<1],pre[N<<1];
int l[N],r[N];bool typ[N];
int n,m,tot=0;
char c[10];
int find(int x){
    if(x==fa[x])return x;
    return fa[x]=find(fa[x]);
}
void merge(int x,int y){fa[find(x)]=find(y);}
int main(){
    scanf("%d%d",&m,&n);
    for(int i=1;i<=n;i++){
        scanf("%d%d%s",&l[i],&r[i],c);
        pre[++tot]=--l[i];
        pre[++tot]=r[i];
        if(c[0]=='e')typ[i]=0;
        else typ[i]=1;
    }
    sort(pre+1,pre+tot+1);
    tot=unique(pre+1,pre+tot+1)-pre-1;
    for(int i=1;i<N*2;i++)fa[i]=i;
    for(int i=1;i<=n;i++){
        l[i]=lower_bound(pre+1,pre+tot+1,l[i])-pre;
        r[i]=lower_bound(pre+1,pre+tot+1,r[i])-pre;
    }
    for(int i=1;i<=n;i++){
        if(typ[i]){
            if(find(OD(l[i]))==find(OD(r[i]))){printf("%d",i-1);return 0;}
            if(find(EV(l[i]))==find(EV(r[i]))){printf("%d",i-1);return 0;}
            merge(OD(l[i]),EV(r[i]));
            merge(EV(l[i]),OD(r[i]));
        }else{
            if(find(OD(l[i]))==find(EV(r[i]))){printf("%d",i-1);return 0;}
            if(find(EV(l[i]))==find(OD(r[i]))){printf("%d",i-1);return 0;}
            merge(OD(l[i]),OD(r[i]));
            merge(EV(l[i]),EV(r[i]));
        }
    }
    printf("%d",n);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Dream_maker_yk/article/details/82228020