Slot Machines + (KMP)

题目描述

Slot machines are popular game machines in casinos. The slot machine we are considering has six places where a figure appears. By combination of figures, one may earn or lose money. There are ten kinds of figures, so we will represent a figure with a number between 0 and 9. Then we can use a six-digit number w = w1w2w3w4w5w6 where 0 ≤ w1, w2, w3, w4, w5, w6 ≤ 9 to represent one possible outcome of the slot machine.

Figure I.1. The layout of a slot machine.


Old slot machines were made up with mechanical components, but nowadays they were replaced by PC-based systems. This change made one critical flaw: they are based on pseudo-random number generators and the outcome sequences of a slot machine are periodic. Let T[i] be the i-th outcome of a slot machine. At first, there is a truly random sequence of length k,T[1],T[2],…,T[k]. Then there exists one positive number such that T[i+p] = T[i]for all possible values of i(>k). Once an attacker can find out the exact values of k and p, he or she can exploit this fact to beat the casino by betting a lot of money when he or she knows the outcome with a good combination in advance.

For example, you have first six numbers of outcome sequences: 612534, 3157, 423, 3157, 423, and 3157. Note that we can remove first 0’s. Therefore, 3157 represents 003157 and 423 represents 000423. You want to know its tenth number. If you know the exact values of k and p, then you can predict the tenth number. However, there are many candidates for k and p: one extreme case is k=5 and p=1, and another is k=0 and p=6. The most probable candidate is the one where both k and p are small. So, our choice is the one with the smallest k+p. If there are two or more such pairs, we pick the one where p is the smallest. With our example, after some tedious computation, we get k=1 and p=2.

Assume that you have n consecutive outcomes of a slot machine, T[1], T[2], …, T[n]. Write a program to compute the values of k and p satisfying the above-mentioned condition.
 

输入

Your program is to read from standard input. The first line contains a positive integer n (1 ≤ n ≤ 1,000,000), representing the length of numbers we have observed up to now in the outcome sequence. The following line contains n numbers. Each of these numbers is between zero and 999,999.

输出

Your program is to write to standard output. Print two integers k and p in one line.

样例输入

6
612534 3157 423 3157 423 3157

样例输出

1 2

题意:数值从1到n ,求从第k+1个数字开始是否可以有循环节大小为p的循环节构成,

例: a b a b a  就是从第一个数开始的循环节为 a b ,即p=2 的一个循环数组,只是最后一个循环节不完整

分析:使用KMP模式匹配 倒置数组的next[] 对应的值的大小,再通过next[ ]数组的遍历,求解k的值即可

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long int
#define maxn 1000010
int mazee[maxn],pandaun[maxn],n;
void getpanduan(){
	int countt=0;
	for(int j=2;j<=n;j++){
        while(countt!=0&&mazee[j]!=mazee[countt+1]) 
			countt=pandaun[countt];
        if(mazee[j]==mazee[countt+1]) 
			countt++;
        pandaun[j]=countt;
    }
}
int main(){
    scanf("%d",&n);
    for(int i=n;i>=1;i--)
        scanf("%d",&mazee[i]);
    getpanduan();
    
  	int x,y;
  	x=y=n;
	for(int i=1;i<=n;i++){
        int xx,yy;
		xx=i-pandaun[i];
		yy=n-i;
		if((xx+yy<x+y)||(xx+yy==x+y&&xx<x)){
			x=xx;
			y=yy;
		}
    }
    printf("%d %d\n",y,x);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/dong_qian/article/details/82940430
kmp