PAT (Advanced Level) Practice A1104 Sum of Number Segments (20 分)(C++)(甲级)(数学基础)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86578540

1104 Sum of Number Segments (20 分)
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4
Sample Output:

5.00

//B1049 数列的片段和 英文版
//https://blog.csdn.net/m0_37454852/article/details/86578354
//第i个数字被累加的次数即(N-i)*i + N-i

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>

double sum = 0, D[100010] = {0};
int main()
{
    int i, N;
    scanf("%d", &N);
    for(i=0; i<N; i++) 
    {
      scanf("%lf", &D[i]);
      sum += D[i] * (N-i)*(i+1);//每个数字乘以被加的次数,再累加即可
    }
    printf("%.2lf", sum);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86578540