Fractions Again?!

It is easy to see that for every fraction in the form 1
k
(k > 0), we can always find two positive integers
x and y, x ≥ y, such that:
1
k

1
x
+
1
y
Now our question is: can you write a program that counts how many such pairs of x and y there
are for any given k?
Input
Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).
Output
For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of
x and y, as shown in the sample output.
Sample Input
2
12
Sample Output
2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24
代码

#include<bits/stdc++.h>
using namespace std;
int xx[1007],yy[1007];
int main()
{
    //freopen("F:\\1234.txt","r",stdin);
    //freopen("F:\\12345.txt","w",stdout);
    int k;
    while(cin>>k)
    {
        int cnt=0;
        for(int y=k+1;y<=k*2;y++)
        {
            double x1=1.0*k*y/(y-k);
            int x=(int)x1;
            if(x*1.0==x1)
            {
                xx[cnt]=x;
                yy[cnt]=y;
                cnt++;
            }
        }
        cout<<cnt<<endl;
        for(int i=0;i<cnt;i++)
            printf("1/%d = 1/%d + 1/%d\n",k,xx[i],yy[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/88696105