strtok-------迭代器

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful. You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.InputThe input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.OutputYour output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.Sample InputAdventures in DisneylandTwo blondes were going to Disneyland when they came to a fork in the road. The sign read: "Disneyland Left."So they went home.Sample Outputaadventuresblondescamedisneylandforkgoinghomeinleftreadroadsignsothetheytotwowentwerewhen

#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
using namespace std;
const int N = 1010;
set<string> dict;
int main(){
 char s[N], delim[] = " ", *p;
 while(cin >> s){
  p = s;
  while(*p){
   if (isalpha(*p))
    *p = tolower(*p);
   else
    *p = ' ';
    p ++;    
  }
   p = strtok(s, delim);
  while(p){
   dict.insert(p);
   p = strtok(NULL, delim);
  }
 }
 for (set<string>::iterator iter = dict.begin(); iter != dict.end(); iter ++)
    cout << *iter << endl;
 return 0;  
} 
发布了106 篇原创文章 · 获赞 67 · 访问量 5434

猜你喜欢

转载自blog.csdn.net/qq_45772483/article/details/104860746
今日推荐