C - Can you solve this equation? HDU - 2199(二分水题)

Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you
find its solution between 0 and 100; Now please try your lucky. Input
The first line of the input contains an integer T(1<=T<=100) which
means the number of test cases. Then T lines follow, each line has a
real number Y (fabs(Y) <= 1e10); Output For each test case, you should
just output one real number(accurate up to 4 decimal places),which is
the solution of the equation,or “No solution!”,if there is no solution
for the equation between 0 and 100. Sample Input

2
100
-4
Sample Output
1.6152
No solution!
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;

#define ll long long  
#define db double
const int Len = 1e5+10;

db Cal(db m)
{
    return 8 * pow(m, 4) + 7 * pow(m, 3) + 2 * pow(m, 2) + 3 * m + 6;
}


int main()
{
    //freopen("A.txt","r",stdin);
    int t;
    cin >> t;
    while(t --)
    {
        int n;
        scanf("%d", &n);
        db l = 0, r = 100;
        if(Cal(0) > n || Cal(100) < n)
            cout << "No solution!\n";
        else
        {
            db m;
            while(r - l >= 1e-10)
            {
                m = (l + r)/2;
                if(Cal(m) > n)
                    r = m;
                else
                    l = m;
            }
            printf("%.4lf\n", m);
        }
    }


    return 0;
}

发布了149 篇原创文章 · 获赞 228 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_34261446/article/details/105037091
今日推荐