7-10 Tree Traversals Again(二叉树)

题目链接:点击打开链接

7-10 Tree Traversals Again(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

//出栈的顺序其实是中序遍历 输出后序遍历
#include<stdio.h>
#include<string.h>
#include<stack> 
using namespace std; 
int n;
int pre[35],ld[35],rd[35];
int ans=0;
void dfs(int u)//输出后序遍历
{
	
	if(ld[u]!=-1)
	dfs(ld[u]);
	if(rd[u]!=-1)
	dfs(rd[u]);
	if(ans==0)
	{
		printf("%d",u);
		ans=1;
	}
	else
	printf(" %d",u);
	
 } 
int main()
{
	int i,u,v;
	char st[20];
	stack<int>s;
	while(!s.empty())
	{
		s.pop();
	}
	scanf("%d",&n);
	scanf("%s",st);
	for(i=1;i<=n;i++)
	{
		pre[i]=i;
		ld[i]=rd[i]=-1;
	}
	if(strcmp(st,"Push")==0)
	{
	    scanf("%d",&u);
	    pre[u]=0;//根节点 
	    s.push(u);
	}
	v=u; 
	int nn=n*2-1;
	//printf("%d\n",nn);
	while(nn--)
	{
		scanf("%s",st);
		if(strcmp(st,"Push")==0)
		{
			scanf("%d",&u);
			//上一步操作的节点是栈顶元素则放入的是左孩子,否则是右孩子 
			if(!s.empty()&&v==s.top())
			{
				pre[u]=v;
				ld[v]=u;//左孩子 
			}
			else
			{
				pre[u]=v;
				rd[v]=u;
			 } 
			 s.push(u);
			 v=s.top(); 
		}
		else
		{
			v=s.top();
			s.pop();
		}
	}
	
	for(i=1;i<=n;i++)
	{
		if(pre[i]==0)
		{
			//dfs(i);
			break;
		}
	}
	//printf("%d\n",i);
	dfs(i);
	printf("\n");
	return 0;
}
 

猜你喜欢

转载自blog.csdn.net/z2664836046/article/details/79680264