hdu1164(素数筛选法)

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11632    Accepted Submission(s): 7159


Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
 
  
11 9412
 

Sample Output
 
  
11 2*2*13*181

所谓的素数筛选,就是用下标记录是素数的为1;

代码:

#include<bits/stdc++.h>
using namespace std;

int a[65536]={0,0,1};
int b[10000];
int main()
{
	int j=0,cnt=0;;
	memset(a,1,sizeof(a));
	for(int i=2; i<=65535; i++)
	{
		if(a[i])
		{
			for(j=i+i; j<=65535; j+=i)
				a[j]=0;
			b[cnt++]=i;
		}
	}
	
	int x;
	while(~scanf("%d",&x))
	{
		for(int i=0; i<=x&&!a[x]; i++)
		{
			if(x%b[i]==0)
			{
				printf("%d*",b[i]);
				x/=b[i];
				i--;
			}
		}
		printf("%d\n",x);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/80433585