基础算法:最大子序列的和

来源PTA

第一题

给定K个整数组成的序列{ N​1​​ , N​2​​ , …, N​K​​ },“连续子列”被定义为{N​i​​ , N​i+1​​ , …, N​j​​ },其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:

数据1:与样例等价,测试基本正确性;
数据2:102个随机整数;
数据3:103个随机整数;
数据4:104个随机整数;
数据5:105个随机整数;
输入格式:
输入第1行给出正整数K (≤100000);第2行给出K个整数,其间以空格分隔。

输出格式:
在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。

输入样例:
6
-2 11 -4 13 -5 -2
输出样例:
20

#include<stdio.h>
int main()
{
	int i,K,num;
	int thissum=0,maxsum=0;
	scanf("%d",&K);
	for(i=0;i<K;i++)
	{
		scanf("%d",&num);
		thissum+=num;
		if(thissum>maxsum) maxsum=thissum;
		else if(thissum<0) thissum=0;
	}
	printf("%d",maxsum);
}


解析:这里使用的算法是“在线处理”
一个循环,复杂度O(N)

第二题

在原来的基础上要求输出子列开始和结束位置
我有点silly
然后瞟了一下QAQ 此处贴上好方法
利用变量tempindex

我的方法:设置计数器 因此不用计开始,只要记结束位置即可

Given a sequence of K integers { N​1​​ , N​2​​ , …, N​K​​ }. A continuous subsequence is defined to be { N​i​​ , N​i+1​​ , …, N​j​​ } where 1≤i≤j≤K.
The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

#include<stdio.h>
int arr[10010];
int main(){
    int n, ThisSum=0, MaxSum=-1, Minindex=0, Maxindex=0, Tempindex=0;
    scanf("%d", &n);
    for(int i=0; i<n; i++)
    {
        scanf("%d", &arr[i]);
        ThisSum+=arr[i];
        if(ThisSum>MaxSum)
        {
            MaxSum=ThisSum;
            Maxindex=i;
            Minindex=Tempindex;
        }
        if(ThisSum<0)
        {
            ThisSum=0;
            Tempindex=i+1;
        }
    }
    if(MaxSum<0)printf("0 %d %d", arr[0], arr[n-1]);
    else{printf("%d %d %d", MaxSum, arr[Minindex], arr[Maxindex]);}
    return 0;
}
发布了46 篇原创文章 · 获赞 13 · 访问量 3696

猜你喜欢

转载自blog.csdn.net/qq_39679772/article/details/103603187
今日推荐