字典序问题,贪心

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

题意为每次都可以从字符串的首部或者尾部提取字母,使得最后的字符串的字典序最小。

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

1,应该注意,字符串是一个一个输入的,在输入时,可以用scanf(" %c", &c);

2,经过思考,可以比较开始和最后数值的大小,输出小的,不过还要考虑到相同的情况,这时应该往下继续比较

代码

#include<stdio.h>
char a[2010];
int main()
{
    int n,left,right,i;
    while(~scanf("%d",&n))
    {
        left=0;
        right=n-1;
        for(i=0; i<n; i++)
            scanf(" %c",&a[i]);
        int ans=0;
        while(left<=right)
        {
            int f=0;
            for(i=0;i+left<=right;i++)
            {
                if(a[left+i]<a[right-i])
                {
                    f=1;
                    break;
                }
                else if(a[left+i]>a[right-i])
                {
                    f=0;
                    break;
                }
            }
            if(f)
                printf("%c",a[left++]);
            else
                printf("%c",a[right--]);
            ans++;
            if(ans==80)
            {
                  printf("\n");
                  ans=0;
            }
        }
        printf("\n");
    }
    return 0;
}

发布了30 篇原创文章 · 获赞 1 · 访问量 244

猜你喜欢

转载自blog.csdn.net/weixin_46204099/article/details/105082814
今日推荐