C 06-图2 Saving James Bond - Easy Version (25分)

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

结构C存放鳄鱼的位置;
结构数组CC存放所有的鳄鱼;
DFS,遍历每一个可以达到的鳄鱼;
因为第一跳可以加上岸边的距离,所以每一个第一跳都为一个连通分量;
遍历所有联通分量,看能否达到岸边。
有一个能就标记flag,停止一切工作,输出Yes;

#include<iostream>
#include<cmath>
using namespace std;

int N,D;

struct C{
	int x;
	int y;
	int visited=0;
}CC[101];
 
int flag;
void DFS(int x,int y)     //起跳点的x和y 
{	
	if(flag==1) return;   //如果找到了 不用继续 
	if(50-abs(x)<=D||50-abs(y)<=D)                     //当可以上岸 
	{
		flag=1;
		return ;
	}
	if(flag!=1){             //没找到,继续操作 
	
	for(int i=0;i<N;i++)        //遍历每一条没经过的鳄鱼,看哪个可以跳 
	{
		int dis=(CC[i].x-x)*(CC[i].x-x)+(CC[i].y-y)*(CC[i].y-y);
		if(!CC[i].visited&&dis<=D*D)     //表示可以跳到
		{
			CC[i].visited=1;         //标记已遍历 
			
			DFS(CC[i].x,CC[i].y);      //继续走 
			CC[i].visited=0;         //走不通标记未遍历 
		 } 
	 }
}
	return;
 } 
 
 
int main()
{	
	cin>>N>>D;     //鳄鱼数量,跳远距离
	for(int i=0;i<N;i++)
	{
		cin>>CC[i].x>>CC[i].y;    //输入每一条鳄鱼的x和y 
	 } 
	flag=0;
	for(int i=0;i<N;i++)
	{	int DIS=(CC[i].x)*(CC[i].x)+(CC[i].y)*(CC[i].y);
		if(DIS<=(7.5+D)*(7.5+D)){
		
			CC[i].visited=1;
			DFS(CC[i].x,CC[i].y);	
		}
		if(flag==1) break;
	}
	
	if(flag==1) cout<<"Yes"<<endl;
	else cout<<"No"<<endl;
}
发布了77 篇原创文章 · 获赞 3 · 访问量 3022

猜你喜欢

转载自blog.csdn.net/BLUEsang/article/details/105401619
今日推荐