1083 List Grades (25分)【结构体排序】

1083 List Grades (25分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

题目大意:

给出n个考生的姓名学号及分数,将这些信息按分数由高到低进行排序,并输出给定区间的考生信息,如果不存在满足条件的考生,则输出NONE。注意所有考生的分数不同。 

解题思路:

结构体排序,注意这道题的所有考生的分数均不同,因此非常简单的结构体排序即可。

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;

struct student {
	string name;
	string id;
	int score;
}stu[110];

int cmp(student a, student b)
{
	return a.score > b.score;
}

int main()
{
	int n, l, h;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> stu[i].name >> stu[i].id >> stu[i].score;
	}
	cin >> l >> h;
	sort(stu, stu + n, cmp);
	int flag = 0;
	for (int i = 0; i < n; i++)
	{
		if (stu[i].score <= h&&stu[i].score >= l)
		{
			flag = 1;
			cout << stu[i].name << " " << stu[i].id << endl;
		}
	}
	if (flag == 0)
		cout << "NONE" << endl;
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104713538