1028 List Sorting (25分)【结构体排序】

1028 List Sorting (25分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

 解题思路:

比较简单的结构体排序,唯一需要注意的是循环中别用cin和cout,会超时。

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

struct student {
	int id;
	string name;
	int score;
}stu[100010];

int n, c;

int cmp(student a, student b)
{
	if (c == 1)
	{
		return a.id < b.id;
	}
	else if (c == 2)
	{
		if (a.name == b.name)
			return a.id < b.id;
		else return a.name < b.name;
	}
	else if (c == 3)
	{
		if (a.score == b.score)
			return a.id < b.id;
		else return a.score < b.score;
	}
}

int main()
{
	cin >> n >> c;
	for (int i = 0; i < n; i++)
	{
		stu[i].name.resize(10);
		scanf("%d %s %d", &stu[i].id, &stu[i].name[0], &stu[i].score);
	}
	sort(stu, stu + n, cmp);
	for (int i = 0; i < n; i++)
	{
		printf("%06d %s %d\n", stu[i].id, stu[i].name.c_str(), stu[i].score);
	}
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104698212