复数计算

定义复数类Complex,并重载运算符:+、-、-=,使复数类对象完成相应的运算。 根据以下代码段,完善??处的内容及程序内容,以实现规定的输出。

class Complex
{
public:
Complex(double r=0, double i=0):real®, imag(i){ }
Complex operator+( ?? ) ; //重载双目运算符’+’
Complex operator-=( ?? ); //重载双目运算符’-=’
friend Complex operator-( ?? ); //重载双目运算符’-’
void Display() const;
private:
double real;
double imag;
};

void Complex::Display() const
{
cout << “(” << real << “,” << imag << “)” << endl;
}
int main()
{
double r, m;
cin >> r >> m;
Complex c1(r, m);
cin >> r >> m;
Complex c2(r, m);
Complex c3 = c1+c2;
c3.Display();
c3 = c1-c2;
c3.Display();
c3 -= c1;
c3.Display();
return 0;
}

输入格式:
输入有两行,分别为两个复数的实部与虚部。

输出格式:
按样例格式输出结果。

输入样例:
在这里给出一组输入。例如:

2 -3
-4 5

输出样例:
在这里给出相应的输出。例如:

(-2,2)
(6,-8)
(4,-5)

#include <iostream>

using namespace std;

class Complex {
public:
    Complex(double r = 0, double i = 0) : real(r), imag(i) {}

    Complex operator+(Complex c) {
        Complex c3;
        c3.real = real + c.real;
        c3.imag = imag + c.imag;
        return c3;
    }              //重载双目运算符'+'
    Complex operator-=(Complex c) {
        real -= c.real;
        imag -= c.imag;
    }            //重载双目运算符'-='
    friend Complex operator-(Complex c1, Complex c2) {
        Complex c3;
        c3.real = c1.real - c2.real;
        c3.imag = c1.imag - c2.imag;
        return c3;
    }    //重载双目运算符'-'
    void Display() const;

private:
    double real;
    double imag;
};

void Complex::Display() const {
    cout << "(" << real << "," << imag << ")" << endl;
}

int main() {
    double r, m;
    cin >> r >> m;
    Complex c1(r, m);
    cin >> r >> m;
    Complex c2(r, m);
    Complex c3 = c1 + c2;
    c3.Display();
    c3 = c1 - c2;
    c3.Display();
    c3 -= c1;
    c3.Display();
    return 0;
}

发布了163 篇原创文章 · 获赞 18 · 访问量 7683

猜你喜欢

转载自blog.csdn.net/xcdq_aaa/article/details/105448576
今日推荐