A - Knight Moves(象棋bfs)

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
 

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
 

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".
 

Sample Input

 
    
e2 e4a1 b2b2 c3a1 h8a1 h7h8 a1b1 c3f6 f6
 

Sample Output

 
    

To get from e2 to e4 takes 2 knight moves.To get from a1 to b2 takes 4 knight moves.To get from b2 to c3 takes 2 knight moves.To get from a1 to h8 takes 6 knight moves.To get from a1 to h7 takes 5 knight moves.To get from h8 to a1 takes 6 knight moves.To get from b1 to c3 takes 1 knight moves.To get from f6 to f6 takes 0 knight moves.


题意:这是一个8*8的棋盘,类似于象棋中的马走日,即一个子可以向左(右)走1个后,再向上(下)走两个;向上(下)走两个,再向左(右)走1个;

思路:bfs

代码:
 
  
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int vis[10][10];
int c[8]={-1,-1,1,1,-2,-2,2,2};
int d[8]={2,-2,2,-2,1,-1,1,-1};
int n,m,t,X,Y;
struct note{
    int x;
    int y;
    int step;
};
note front_head;
int bfs()
{
    queue<note> q;
    q.push(front_head);
    note next_queue;
    note now_head;
    while(!q.empty())
    {
        now_head=q.front();
        q.pop();
        if(now_head.x==X&&now_head.y==Y)
                return now_head.step;
        for(int i=0;i<8;i++)
        {
            next_queue.x=now_head.x+c[i];
            next_queue.y=now_head.y+d[i];
            if(next_queue.x>=1&&next_queue.x<=8&&next_queue.y>=1&&next_queue.y<=8&&vis[next_queue.x][next_queue.y]==0)
            {
                  vis[next_queue.x][next_queue.y]=1;
                  next_queue.step = now_head.step+1;
                  q.push(next_queue);
            }
        }
     }





}
int main()
{
    char a[3],b[3];
    int ans;
    while(scanf("%s %s",&a,&b)!=EOF)
    {

        memset(vis,0,sizeof(vis));
        front_head.x=a[0]-96;
        front_head.y=a[1]-48;
        front_head.step=0;
        X=b[0]-96;
        Y=b[1]-48;
        
        if(front_head.x==X&&front_head.y==Y)
            ans=0;
        else
            ans=bfs();
        printf("To get from %s to %s takes %d knight moves.\n",a,b,ans);



    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41700151/article/details/80186799
今日推荐