POJ - 3696 The Luckiest number 【欧拉函数】

Description

Chinese people think of '8' as the lucky digit. Bob also likes digit '8'. Moreover, Bob has his own lucky number L. Now he wants to construct his luckiest number which is the minimum among all positive integers that are a multiple of L and consist of only digit '8'.

Input

The input consists of multiple test cases. Each test case contains exactly one line containing L(1 ≤ L ≤ 2,000,000,000).

The last test case is followed by a line containing a zero.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the length of Bob's luckiest number. If Bob can't construct his luckiest number, print a zero.

Sample Input

8
11
16
0

Sample Output

Case 1: 1
Case 2: 2
Case 3: 0
#include<stdio.h>
#include<string.h>

#define LL long long

LL gcd(LL a, LL b) {
    return b == 0 ? a : gcd(b, a%b);
}

//φ(n)
LL eular(LL n) {
    LL ans = n;
    for (LL i = 2; i*i <= n; i++)
        if (n%i == 0) {
            ans -= ans / i;
            while(n%i == 0) n /= i;
        }
    if (n > 1) 
        ans -= ans / n;
    return ans;
}

//a*b%p
LL p;
LL multi(LL a, LL b) {
    LL ans = 0;
    while(b) {
        if (b & 1) ans = (ans + a) % p;
        a = a * 2 % p;
        b >>= 1;
    }
    return ans;
}

//a^b%p
LL power_mod(LL a, LL b) {
    LL ans = 1;
    while(b) {
        if (b & 1) 
            ans = multi(ans, a);
        a = multi(a, a);
        b >>= 1;
    }
    return ans;
}

int main() {
    int iCase = 1;
    int L;
    while (scanf("%d", &L) != EOF && L) {
        p = L / gcd(L, 8) * 9;
        if (gcd(10,p)!=1 || L%5==0) {
            printf("Case %d: 0\n", iCase++);
            continue;
        }
        LL n = eular(p);
        LL number = n;
        for (LL i = 2; i*i < n; i++)
            if (n%i == 0) {
                int cnt = 0;
                while (n%i == 0) {
                    cnt++;
                    n /= i;
                }
                while (cnt)
                {
                    if (power_mod(10, number/i) % p == 1) {
                        number /= i;
                        cnt--;
                    }
                    else break;
                }
            }
        if(n>1 && power_mod(10, number/n)%p == 1) 
            number /= n;
        printf("Case %d: %lld\n", iCase++, number);
    }

    return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105479365
今日推荐