HDU - 2032 杨辉三角

Description

还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1

Input

输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。

Output

对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。

Sample Input

2 3

Sample Output

1
1 1

1
1 1
1 2 1
#include <cstdio>

using namespace std;

int a[31][31];

int main ()
{
	int n;
    while (scanf ("%d",&n)!= EOF)
    {
        for (int i = 0; i < n; i++)
            for (int j = 0; j <= i; j++)
            {
                if (j == 0 || j == i)
                    a[i][j] = 1;
                else
                    a[i][j] = a[i-1][j-1] + a[i-1][j];
            }
        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < i; j++)
                printf("%d ", a[i][j]);
            printf("%d", a[i][i]);
            printf("\n");
        }
        printf ("\n");
    }
    return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105320404