动态规划13 Human Gene Functions

Human Gene Functions

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100. 

Output

The output should print the similarity of each test case, one per line. 

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14 
21 
AC代码

#include<iostream>
#include<map>
#include<algorithm>
#include<string>
using namespace std;

#define MAX 107

int D[113][113];
long long dp[MAX][MAX];//状态转移方程 dp[i][j]表示的是前i个str1与前j个str2结合的最大值
                       //考虑前面一个状态,也就是考虑第i个和第j个,有三种情况,第一种第i个和第j个匹配,第二种,第i个和空格匹配,第三种空格和第j个匹配

char str1[MAX];
char str2[MAX];

long long maxb(long long a, long long b, long long c)
{
	if (a >= b&&a >= c) return a;
	if (b >= a&&b >= c) return b;
	if (c >= a&&c >= b) return c;
}

int main()
{
	D['A']['A'] = D['C']['C'] = D['G']['G'] = D['T']['T'] = 5;
	D['A']['C'] = D['C']['A'] = -1;
	D['A']['G'] = D['G']['A'] = -2;
	D['A']['T'] = D['T']['A'] = -1;
	D['A']['-'] = D['-']['A'] = -3;
	D['C']['G'] = D['G']['C'] = -3;
	D['C']['T'] = D['T']['C'] = -2;
	D['C']['-'] = D['-']['C'] = -4;
	D['G']['T'] = D['T']['G'] = -2;
	D['G']['-'] = D['-']['G'] = -2;
	D['T']['-'] = D['-']['T'] = -1;//数组只要够AGCT-的ASII值就行了,因为他会自动将AGCT转化为对应的数值
	D['-']['-'] = -INT_MAX;
	dp[0][0] = 0;
	int t;
	cin >> t;
	int n1, n2;
	while (t--)
	{
		cin >> n1;
		for (int i = 1; i <= n1; ++i)
		{
			cin >> str1[i];
			dp[i][0] = dp[i - 1][0] + D[str1[i]]['-'];//初始条件设置
		}
		cin >> n2;
		for (int i = 1; i <= n2; ++i)
		{
			cin >> str2[i];
			dp[0][i] = dp[0][i - 1] + D['-'][str2[i]];//初始条件设置
		}
		for (int i = 1; i <= n1; ++i)
		{
			for (int j = 1; j <= n2; ++j)
			{
				dp[i][j] = maxb(dp[i - 1][j - 1] + D[str1[i]][str2[j]], dp[i - 1][j] + D[str1[i]]['-'], dp[i][j - 1] + D['-'][str2[j]]);
			}
		}
		cout << dp[n1][n2] << endl;
	}
	system("pause");
	return 0;

}




猜你喜欢

转载自blog.csdn.net/qq_36921652/article/details/79187419
今日推荐