POJ 2112 Optimal Milking

POJ 2112 Optimal Milking

题目链接

Description

FJ has moved his K (1 <= K <= 30) milking machines out into the cow pastures among the C (1 <= C <= 200) cows. A set of paths of various lengths runs among the cows and the milking machines. The milking machine locations are named by ID numbers 1…K; the cow locations are named by ID numbers K+1…K+C.

Each milking point can “process” at most M (1 <= M <= 15) cows each day.

Write a program to find an assignment for each cow to some milking machine so that the distance the furthest-walking cow travels is minimized (and, of course, the milking machines are not overutilized). At least one legal assignment is possible for all input data sets. Cows can traverse several paths on the way to their milking machine.

Input

  • Line 1: A single line with three space-separated integers: K, C, and M.

  • Lines 2… …: Each of these K+C lines of K+C space-separated integers describes the distances between pairs of various entities. The input forms a symmetric matrix. Line 2 tells the distances from milking machine 1 to each of the other entities; line 3 tells the distances from machine 2 to each of the other entities, and so on. Distances of entities directly connected by a path are positive integers no larger than 200. Entities not directly connected by a path have a distance of 0. The distance from an entity to itself (i.e., all numbers on the diagonal) is also given as 0. To keep the input lines of reasonable length, when K+C > 15, a row is broken into successive lines of 15 numbers and a potentially shorter line to finish up a row. Each new row begins on its own line.

Output

A single line with a single integer that is the minimum possible total distance for the furthest walking cow.

Sample Input

2 3 2
0 3 2 1 1
3 0 3 2 0
2 3 0 1 0
1 2 1 0 2
1 0 0 2 0

Sample Output

2

题意是有 k k 台机器, c c 头奶牛,给出他们之间的距离,求每头奶牛都能分配到机器的情况下奶牛与机器的最远距离的最小值~
先用 f l o y d floyd 算法求出最短路,对最远距离的最小值,很容易想到二分答案,对每一个距离,套一个二分多重匹配模板即可,AC代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=305;
const int inf=1e8;
int link[N][N],vis[N],G[N][N],num[N],g[N][N];
int k,c,w,dis;
int found(int u){
    for(int v=0;v<k;v++){
        if(!vis[v] && g[u][v]){
            vis[v]=1;
            if(num[v]<w){
                link[v][num[v]++]=u;
                return 1;
            }
            for(int i=0;i<num[v];i++){
                if(found(link[v][i])){
                    link[v][i]=u;
                    return 1;
                }
            }
        }
    }
    return 0;
}

int hungary(int lim){
    fill(link[0],link[0]+N*N,0);
    fill(num,num+N,0);
    for(int i=0;i<c;i++){
        fill(vis,vis+N,0);
        if(!found(i)) return 0;
    }
    return 1;
}

void floyd(){
    for(int u=0;u<k+c;u++){
        for(int i=0;i<k+c;i++){
            for(int j=0;j<k+c;j++)
                G[i][j]=min(G[i][j],G[i][u]+G[u][j]);
        }
    }
}

void build(int lim){
    fill(g[0],g[0]+N*N,0);
    for(int i=k;i<k+c;i++){
        for(int j=0;j<k;j++)
            if(G[i][j]<=lim) g[i-k][j]=1;
    }
}

int main(){
    while(~scanf("%d%d%d",&k,&c,&w)){
        fill(G[0],G[0]+N*N,0);
        fill(vis,vis+N,0);
        for(int i=0;i<k+c;i++){
            for(int j=0;j<k+c;j++){
                scanf("%d",&dis);
                dis==0?G[i][j]=inf:G[i][j]=dis;
            }
        }
        floyd();
        int l=1,r=inf;
        while(l<=r){
            int mid=(l+r)>>1;
            build(mid);
            if(hungary(mid)) r=mid-1;
            else l=mid+1;
        }
        printf("%d\n",l);
    }
    return 0;
}
发布了479 篇原创文章 · 获赞 38 · 访问量 18万+

猜你喜欢

转载自blog.csdn.net/qq_43765333/article/details/105659261