ZZULIOJ-1094,统计元音(函数专题)(Python)

题目描述:

输入一个字符串,统计其中元音字母的个数。要求使用函数vowel()用来判断是否为元音,其余功能在main()函数中实现。 
int vowel(char ch)
{
             //如果ch是元音,返回1,否则返回0
}

本题如果是C/C++代码提交,只需要提交vowel函数的定义部分,提交其它内容,编译出错。

输入:

输入一个字符串,长度不超过1000,以回车符结束。  

输出: 

输出一个整数,表示元音字母个数。输出单独占一行。  

样例输入: 

Hello world! 

样例输出: 

程序代码: 

s=input()
x=s.count("a")+s.count("e")+s.count("i")+s.count("o")+s.count("u")
y=s.count("A")+s.count("E")+s.count("I")+s.count("O")+s.count("U")
print(x+y)
原创文章 433 获赞 456 访问量 6万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/105771540