【一只蒟蒻的刷题历程】 【PAT (Advanced Level) Practice】 1005 正确拼写

1005 Spell It Right (20分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five


题目大意:

1005正确拼写(20分)

给定一个非负整数N,您的任务是计算N的所有数字的总和,并以英语输出总和的每个数字。

输入规格:

每个输入文件包含一个测试用例。 每种情况占用一条线,其中包含N(≤10100)。

输出规格:

对于每个测试用例,请一行用英语单词输出总和的数字。 两个连续的单词之间必须有一个空格,但行尾不能有多余的空格。
样本输入:
12345

样本输出:

one five


代码:

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
int main() 
{
   char english[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
   string s;
   getline(cin,s);
   long long sum=0;
   for(int i=0;i<s.length();i++)
      sum+=s[i]-'0';
   vector<string> ans;
   if(sum==0) cout<<english[0];  //测试点2
   while(sum)
   {
   	   ans.push_back(english[sum%10]);
   	   sum/=10;
   }
   for(int i=ans.size()-1;i>=0;i--)
   {
   	   cout<<ans[i];
   	   if(i>=1)
   	   cout<<" ";
   }
    return 0;
}

原创文章 32 获赞 35 访问量 1519

猜你喜欢

转载自blog.csdn.net/weixin_45260385/article/details/105892995
今日推荐