prime最小生成树

Truck History
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31871   Accepted: 12427

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.
题意:
给你一个n;
n个长为7的字符串;
每个字符串表示一个节点,每个节点向其他所有点都有边,边长为两个节点字符串同一位置不同字符的数量;
需要你生成最短路的边权和。
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define N 2010
#define M 10

char str[N][M];//放字符串 
int n;//结点数 
int vis[N],dst[N],map[N][N]; //vis访问数组,dst放各点到MST的最小距离 

int finddst(int i,int j)//找两字符串字符不同的列数 
{
	int num=0,k;
	
	for (k=0;k<7;k++)
	{
		if(str[i][k]!=str[j][k])
		{
			num++;
		}
	}
	return num;
}

void init()
{
	int j,i;
	
	memset(vis,0,sizeof(vis));//访问数组初始 
	for (i=0;i<n;i++)//初始化图 
	{
		for (j=0;j<n;j++)
		{
			if (i==j)
			{
				map[i][j]=0;
			}
			
			map[i][j]=finddst(i,j);			
		}
	}
}

void prime()
{
	int i,j,min,point,ans=0;
	
	vis[0]=1;//0点放入MST 
	for (i=0;i<n;i++)//dst初始化 
	{
		dst[i]=map[i][0];
	}
	
	for (i=1;i<n;i++)
	{
		min=N;
		for (j=0;j<n;j++)//找距MST最近的点 
		{
			if (vis[j]==0&&min>dst[j])
			{
				min=dst[j];
				point=j;
			}
		}
		
		if (min==N)//不连通情况 
		{
			break;
		}
		
		vis[point]=1;//把该点放入MST 
		ans=ans+dst[point];
		
		for (j=0;j<n;j++)//更新各点到MST的最小距离 
		{
			if (vis[j]==0&&dst[j]>map[point][j])
			{
				dst[j]=map[point][j];
			}
		}
	}
	
	printf("The highest possible quality is 1/%d.\n",ans);
}

int main()
{
	int i,j;
	
	while (scanf("%d",&n)&&n)
	{
		for (i=0;i<n;i++)
		{
			scanf("%s",&str[i]);
		}
		
		init();
		prime();
	}
	
	return 0;
} 

猜你喜欢

转载自www.cnblogs.com/hemeiwolong/p/8994133.html