POJ - 2823 Sliding Window 【 单调队列 】详细题解

1.题目

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input
8 3
1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7

2.代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1e6 + 10;
int p[maxn], q[maxn], a[maxn];
int main()
{
	int n, k;
	scanf("%d%d", &n, &k);
	for (int i = 1; i <= n; i++)
		scanf("%d", &a[i]);
	///求最小值  单调递增队列 
	int head = 1, tail = 0, flag=1;
	for (int i = 1; i <= n; i++)
	{
		while (head <= tail && a[i] <= q[tail])
			tail--;
		q[++tail] = a[i];
		p[tail] = i;
		while (p[head] <= i - k)
			head++;
		if (i >= k)
		{
			if (flag)
			{
				printf("%d",q[head]);
				flag = 0;
			}
			else
				printf(" %d",q[head]);
 		}
	}
	cout << endl;
	memset(p, 0, sizeof(p));
	memset(q, 0, sizeof(q));
	////求最大值   单调递减队列 
	head = 1;
	tail = 0;
	flag = 1;
	for (int i = 1; i <= n; i++)
	{
		while (head <= tail && a[i] >= q[tail])
			tail--;
		q[++tail] = a[i];
		p[tail] = i;
		while (p[head] <= i - k)
			head++;
		if (i >= k)
		{
			if (flag)
			{
				cout << q[head];
				flag = 0;
			}
			else
				cout << ' '<< q[head];
		}
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_45629285/article/details/106411362