POJ2594 Treasure Exploration(二分图匹配+匈牙利算法+Floyd+传递闭包)

POJ2594 Treasure Exploration(二分图匹配+匈牙利算法+Floyd+传递闭包)

Description
Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?
Input
The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.
Output
For each test of the input, print a line containing the least robots needed.
Sample Input
1 0
2 1
1 2
2 0
0 0
Sample Output
1
1
2

题意

给定n个点,有m条单向边将其连接。问最小边覆盖是多少。二分图匹配裸题。先用Floyd求出其传递闭包,再用匈牙利算法求解即可。数据较小直接用邻接矩阵存边。最小边覆盖=点的个数n-最大匹配数。

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<functional> 
#include<map>
//#include<unordered_map>
#define lowbit(x) ((x)&-(x));
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N=1e6+10,NN=5e2+10,INF=0x3f3f3f3f,LEN=20;
const ll MOD=1e9+7;
const ull seed=31;
int n,m;
int match[N];
int mp[NN][NN];
bool reverse_boy[N];
bool dfs(int u){
	for(int v=1;v<=n;v++){
		if(v==u) continue;
		if(!reverse_boy[v]&&mp[u][v]==1){
			reverse_boy[v]=true;
			if(match[v]==-1||dfs(match[v])){
				match[v]=u;
				return true;
			}
		}
	}
	return false;
}
void floyd(){//求出传递闭包
	for(int k=1;k<=n;k++){
		for(int i=1;i<=n;i++){
			if(mp[i][k]==INF) continue;
			for(int j=1;j<=n;j++) if(mp[k][j]!=INF) mp[i][j]=1;
		}
	}
}
void init(){
	memset(mp,INF,sizeof mp);
	memset(match,-1,sizeof match);
}
int main(){
	while(scanf("%d%d",&n,&m)&&(n+m)){
		init();
		if(m==0){
			printf("%d\n",n);
			continue;
		}
		for(int i=1;i<=m;i++){
			int u,v;
			scanf("%d%d",&u,&v);
			mp[u][v]=1;
		}
		floyd();
		int ans=0;
		for(int i=1;i<=n;i++){
			memset(reverse_boy,false,sizeof reverse_boy);
			if(dfs(i)) ++ans;
		}
		printf("%d\n",n-ans);
	}
}

猜你喜欢

转载自blog.csdn.net/Hc_Soap/article/details/107771498