ayit第十周训练d题

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2. 

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder. 

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder. 

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r. 

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence. 

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree. 

Output

For each test case print a single line specifying the corresponding postorder sequence. 

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

Sample Output

7 4 2 8 9 5 6 3 1
#include<stdio.h>
#include<string.h>
int p[1000],p1[1000];
void s1(int a,int b,int n,int q)
{
    if(n==1)
    {
        printf("%d ",p[a]);
        return ;
    }
    else if(n<=0)
        return ;
    int i;
    for(i=0;p[a]!=p1[b+i];i++);
        s1(a+1,b,i,0);
        s1(a+i+1,b+i+1,n-i-1,0);
    if(q==1)
            printf("%d",p[a]);
    else
        printf("%d ",p[a]);
}
 
int main ( )
{
    int i,n;
    while(~scanf("%d",&n))
    {
    for(i=1;i<=n;i++)
        scanf("%d",&p[i]);
    for(i=1;i<=n;i++)
        scanf("%d",&p1[i]);
    s1(1,1,n,1);
    printf("\n");
    }
    return 0;
}

题型   二叉树

题意   已知前序序列和中序序列求后续序列

思路   前序遍历和中序遍历相应区间中前序遍历第一个数是当前树的根节点,在中序遍历中找到这个数,区间中这个数左边                    的数字都在此数左孩子中的小树里,区间中这个数右边的数字都在此数右孩子中的小树里  左节点在前面输出,右节点在              后面输出,根节点最后输出

猜你喜欢

转载自blog.csdn.net/m0_46628834/article/details/105848920