Codeup——604 | 问题 C: 数组逆置

题目描述

输入一个字符串,长度小于等于200,然后将数组逆置输出。

输入

测试数据有多组,每组输入一个字符串。

输出

对于每组输入,请输出逆置后的结果。

样例输入

tianqin

样例输出

niqnait

提示

注意输入的字符串可能会有空格。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    
    
	char str[201];
	while(gets(str)){
    
    
		reverse(str,str+strlen(str));
		cout <<str<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_44888152/article/details/107028268