Codeup——597 | 问题 A: Set Similarity (25)

题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出

50.0%
33.3%

思路:很显然使用set来做这个题,思路是把两个集合(假设为a,b)里的元素放进一个新的集合里,这个新集合里的元素的个数就是Nt,而Nc的值就是a和b两个集合的元素个数相加再减取Nt,但是这样的话算法的时间复杂度较高,因此换一个思路,在b集合里找a集合元素,找到的话Nc加1,因为find()的时间复杂度比较优秀。而Nt的值就是a和b两个集合里的元素个数之和减去Nc,虽然耗时还是很高,但是可以AC。

#include <iostream>
#include <cstdio>
#include <set>
using namespace std;

int main()
{
    
    
	set<int> s[10000];
	int i,j,n,m,k,x,a,b;
	scanf("%d",&n);
	for(i=0;i<n;i++){
    
    
		scanf("%d",&m);
		for(j=0;j<m;j++){
    
    
			scanf("%d",&x);
			s[i+1].insert(x); 
		}
	}
	scanf("%d",&k);
	double Nc,Nt;
	for(i=0;i<k;i++){
    
    
		scanf("%d%d",&a,&b);
		set<int>::iterator it;
		Nc=0;
		for(it=s[a].begin();it!=s[a].end();it++){
    
    
			if(s[b].find(*it)!=s[b].end())
				Nc++;
		}
		Nt=s[a].size()+s[b].size()-Nc;
		printf("%.1lf%\n",Nc*100/Nt);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_44888152/article/details/106984087