求众数Majority Element

求众数Majority Element

Problem description
Given an array of size n, find the majority element. The majority element is the element that appears more than ⌊ n/2 ⌋ times.
You may assume that the array is non-empty and the majority element always exist in the array.
The range of length of array is n(1≤n≤5,000,000) and the element (integer) in array is no bigger than 10,000,00000.
Input
Line 1: the length of array.
Line 2: the all elements in array and split by spaces
Output
Line 1: A single integer that is the majority element.
Sample Input 1
3
2 3 2
Sample Output 1
2
Sample Input 2
7
2 1 2 2 3 3 2
Sample Output 2
2

#include <iostream>
#include <vector>
using namespace std;
int main() {
    
    
    int a;
    cin>>a;
    int nums[a];
    for(int i=0;i<a;i++)
        cin>>nums[i];
     int flag=nums[0];
        int count=1;
        for(int i=1;i<a;i++){
    
    
            if(count==0){
    
    
                count ++;
                flag=nums[i];
            }else if(flag==nums[i]){
    
    
                count++;
            }else{
    
    
                count--;
            }
        }
 cout<<flag; 
 return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38491875/article/details/102566384