C语言 圆形体体积计算器

圆形体体积计算器

题目描述:

本题要求实现一个常用圆形体体积的计算器。计算公式如下: 球体体积 V= ​ ​4/3πr ​3 ​​ ,其中r是球体半径。 圆柱体体积 V=πr ​2 ​​h,其中r是底圆半径,h是高。 圆锥体体积 V= ​1/3πr 2 ​h,其中r是底圆半径,h是高。
输入格式:
在每次计算之前,要求输出如下界面:
1-Ball
2-Cylinder
3-Cone other-Exit Please enter your command:
然后从标准输入读进一个整数指令。
输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。
当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。 计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4
3 0

输出样例:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

代码如下:

#include "stdio.h"
#include "math.h"
int lifter()
{
    
    
	int n;
	double v1,v2,v3,r,h,p=3.1415;
	while(1)//判断指令是1或2或3 
	{
    
    
		scanf("%d",&n);//输入指令 
		printf("1-Ball\n2-Cylinder\n3-Cone\nother-Exit\nPlease enter your command:\n");
		if(n==1)//球体体积
		{
    
    
			scanf("%lf",&r);
			printf("Please enter the radius:\n");
			v1=4.0/3*p*pow(r,3);
			printf("%.2lf\n",v1);
		}
		else if(n==2)//圆柱体体积
		{
    
    
			scanf("%lf%lf",&r,&h);
			printf("Please enter the radius and the height:\n");
			v2=p*pow(r,2)*h;
			printf("%.2lf\n",v2);
		}
		else if(n==3)//圆锥体体积
		{
    
    
			scanf("%lf%lf",&r,&h);
			printf("Please enter the radius and the height:\n");
			v3=1.0/3*p*pow(r,2)*h;
			printf("%.2lf\n",v3);
		}
		else//其他整数结束程序 
			return 0;
	}
}
int main()
{
    
    
	lifter();
	return 0;
}

运行结果如下图:
在这里插入图片描述

猜你喜欢

转载自blog.csdn.net/AMCUL/article/details/108436771