【SSL_1344】Knights

Knights


Description

We are given a chess-board of size nn, from which some fields have been removed. The task is to determine the maximum number of knights that can be placed on the remaining fields of the board in such a way that none of them check each other.
一张大小为n
n的国际象棋棋盘,上面有一些格子被拿走了,棋盘规模n不超过200。马的攻击方向如下图,其中S处为马位置,标有X的点为该马的攻击点。
Fig.1: A knight placed on the field S checks fields marked with x.
Write a program, that:
reads the description of a chess-board with some fields removed, from the input file kni.in,
determines the maximum number of knights that can be placed on the chess-board in such a way that none of them check each other,
writes the result to the output file kni.out.
你的任务是确定在这个棋盘上放置尽可能多的马,并使他们不互相攻击。

Input

The first line of the input file kni.in contains two integers n and m, separated by a single space, 1<=n<=200, 0<=m<n2; n is the chess-board size and m is the number of removed fields. Each of the following m lines contains two integers: x and y, separated by a single space, 1<=x,y<=n – these are the coordinates of the removed fields. The coordinates of the upper left corner of the board are (1,1), and of the bottom right are (n,n). The removed fields are not repeated in the file.

Output

The output file kni.out should contain one integer (in the first and only line of the file). It should be the maximum number of knights that can be placed on the given chess-board without checking each other.

Sample Input

3 2
1 1
3 3

Sample Output

5

解题思路

先连边(黑连白),再套模板就行了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

long long n,m,a[2010][2010];
long long tot,hd[40010],cv[40010],fa[40010];

const int xn[9]={
    
    0,1,2,2,1,-1,-2,-2,-1};
const int yn[9]={
    
    0,2,1,-1,-2,-2,-1,1,2};

struct abc{
    
    
	int to,next;
}s[4000000];

long long hh(int x,int y)
{
    
    
	return (x-1)*n+y;
}

void add(int x,int y)
{
    
    
	s[++tot]=(abc){
    
    y,hd[x]};
	hd[x]=tot;
}

bool find(int x)
{
    
    
	for(int i=hd[x];i;i=s[i].next)
		if(!cv[s[i].to])
		{
    
    
			int y=s[i].to;
			cv[y]=1;
			int q=fa[y];
			fa[y]=x;
			if(q==0||find(q)) return 1;
			fa[y]=q;
		}
	return 0;
}

int main()
{
    
    
	cin>>n>>m;
	for(int i=1;i<=m;i++)
	{
    
    
		int x,y;
		scanf("%d%d",&x,&y);
		a[x][y]=1;
	}
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
			if(!a[i][j]&&(i+j)%2==0)
				for(int k=1;k<=8;k++)
				{
    
    
					int x=i+xn[k],y=j+yn[k];
					if(x>0&&x<=n&&y>0&&y<=n&&!a[x][y])
						add(hh(i,j),hh(x,y));
				}
	long long ans=0;
	for(int i=1;i<=n*n;i++)
	{
    
    
		memset(cv,0,sizeof(cv));
		if(find(i)) ans++;
	}
	cout<<n*n-m-ans<<endl; 
}

猜你喜欢

转载自blog.csdn.net/SSL_guyixin/article/details/108156444
SSL