PTA 团队赛 L1-023 输出GPLT (20point(s))

题目:

  给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

  输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

  在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL
#include<stdio.h>
#include<string.h>
int main(){
    
    
	char a[10001];
    gets(a);
	int g=0,p=0,l=0,t=0;
	for(int i=0;i<=strlen(a);i++)
	{
    
    
		if(a[i]=='g'||a[i]=='G'){
    
     
			g++;
		} 
		else if(a[i]=='p'||a[i]=='P'){
    
     
			p++;
		}	 
		else if(a[i]=='l'||a[i]=='L')
			l++;
		else if(a[i]=='t'||a[i]=='T')
			t++;
	}	
	for(;g>0||p>0||l>0||t>0;g--,p--,l--,t--){
    
    
		if(g>0)
		printf("G");
		if(p>0)
		printf("P");
		if(l>0)
		printf("L");
		if(t>0)
		printf("T");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_43515862/article/details/108097615