HCIP第六天作业

实验要求
在这里插入图片描述
实验拓扑
在这里插入图片描述

1.配置IP地址及环回地址
R1:
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 16.1.1.1 24
[R1-GigabitEthernet0/0/0]q
[R1]interface g0/0/1
[R1-GigabitEthernet0/0/1]ip address 61.1.1.1 24
[R1-GigabitEthernet0/0/1]q
[R1]interface LoopBack 0
[R1-LoopBack0]IP address 1.1.1.1 24

R2:
[R2]interface g0/0/0
[R2-GigabitEthernet0/0/0]ip address 26.1.1.1 24
[R2-GigabitEthernet0/0/0]q
[R2]interface LoopBack 0
[R2-LoopBack0]ip address 2.2.2.2 24

R3:
[R3]interface g0/0/0
[R3-GigabitEthernet0/0/0]ip address 36.1.1.1 24
[R3-GigabitEthernet0/0/0]q
[R3]interface LoopBack 0
[R3-LoopBack0]ip address 3.3.3.3 24

R4:
[R4]interface g0/0/0
[R4-GigabitEthernet0/0/0]ip address 46.1.1.1 24
[R4-GigabitEthernet0/0/0]q
[R4]interface LoopBack 0
[R4-LoopBack0]ip address 4.4.4.4 24
[R4-LoopBack0]q

R5:
[R5]interface g0/0/0
[R5-GigabitEthernet0/0/0]ip address 56.1.1.1 24
[R5-GigabitEthernet0/0/0]q
[R5]interface LoopBack 0
[R5-LoopBack0]ip address 5.5.5.5 24

R6:
[R6]interface g0/0/0
[R6-GigabitEthernet0/0/0]ip address 16.1.1.2 24
[R6-GigabitEthernet0/0/0]q
[R6]interface g0/0/1
[R6-GigabitEthernet0/0/1]ip address 61.1.1.2 24
[R6-GigabitEthernet0/0/1]q
[R6]interface g0/0/2
[R6-GigabitEthernet0/0/2]ip address 26.1.1.2 24
[R6-GigabitEthernet0/0/2]q
[R6]interface g6/0/0
[R6-GigabitEthernet6/0/0]ip address 36.1.1.2 24
[R6-GigabitEthernet6/0/0]q
[R6]interface g6/0/1
[R6-GigabitEthernet6/0/1]ip address 46.1.1.2 24
[R6-GigabitEthernet6/0/1]q
[R6]interface g6/0/2
[R6-GigabitEthernet6/0/2]ip address 56.1.1.2 24
[R6-GigabitEthernet6/0/2]q
[R6]interface LoopBack 0
[R6-LoopBack0]ip address 6.6.6.6 24
[R6-LoopBack0]q

2.配置缺省路由,公网可通

R1:
[R1]ip route-static 0.0.0.0 0 16.1.1.2
[R1]ip route-static 0.0.0.0 0 61.1.1.2

R2:
[R2]ip route-static 0.0.0.0 0 26.1.1.2

R3:
[R3]ip route-static 0.0.0.0 0 36.1.1.2

R4:
[R4]ip route-static 0.0.0.0 0 46.1.1.2

R5:
[R5]ip route-static 0.0.0.0 0 56.1.1.2

3.R1/4/5为全连的MGRE结构

R1:
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 16.1.1.1
[R1-Tunnel0/0/0]nhrp entry multicast dynamic
[R1-Tunnel0/0/0]nhrp network-id 100
[R1-Tunnel0/0/0]q

R4:
[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 10.1.1.2 24
[R4-Tunnel0/0/0]tunnel-protocol gre p2mp
[R4-Tunnel0/0/0]source g0/0/0
[R4-Tunnel0/0/0]nhrp network-id 100
[R4-Tunnel0/0/0]nhrp entry 10.1.1.1 16.1.1.1 register
[R4-Tunnel0/0/0]nhrp entry 10.1.1.3 56.1.1.1 register
[R4-Tunnel0/0/0]nhrp entry multicast dynamic

R5:
[R5]interface Tunnel 0/0/0
[R5-Tunnel0/0/0]ip address 10.1.1.3 24
[R5-Tunnel0/0/0]tunnel-protocol gre p2mp
[R5-Tunnel0/0/0]source g0/0/0
[R5-Tunnel0/0/0]nhrp network-id 100
[R5-Tunnel0/0/0]nhrp entry 10.1.1.1 16.1.1.1
[R5-Tunnel0/0/0]nhrp entry 10.1.1.1 16.1.1.1 register
[R5-Tunnel0/0/0]nhrp entry 10.1.1.2 46.1.1.1 register
[R5-Tunnel0/0/0]nhrp entry multicast dynamic

4.R1/2/3为星型拓扑结构,R1为中心站点

R1:
[R1]interface Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 11.1.1.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre p2mp
[R1-Tunnel0/0/1]source 61.1.1.1
[R1-Tunnel0/0/1]nhrp entry multicast dynamic
[R1-Tunnel0/0/1]nhrp network-id 100
[R1-Tunnel0/0/1]q

R2:
[R2]interface Tunnel 0/0/1
[R2-Tunnel0/0/1]ip address 11.1.1.2 24
[R2-Tunnel0/0/1]tunnel-protocol gre p2mp
[R2-Tunnel0/0/1]source g0/0/0
[R2-Tunnel0/0/1]nhrp entry 11.1.1.1 61.1.1.1 register

R3:
[R3]interface Tunnel 0/0/1
[R3-Tunnel0/0/1]ip address 11.1.1.3 24
[R3-Tunnel0/0/1]tunnel-protocol gre p2mp
[R3-Tunnel0/0/1]source g0/0/0
[R3-Tunnel0/0/1]nhrp entry 11.1.1.1 61.1.1.1

5.私有网络启动OSPF协议

R1:
[R1-ospf-1]dis this
[V200R003C00]

ospf 1 router-id 1.1.1.1
area 0.0.0.0
network 1.1.1.1 0.0.0.0
network 10.1.1.0 0.0.0.255
network 11.1.1.0 0.0.0.255

return

R2:

[R2-ospf-1-area-0.0.0.0]dis this
[V200R003C00]

area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 11.1.1.0 0.0.0.255

return

R3:
[R3-ospf-1-area-0.0.0.0]dis this
[V200R003C00]

area 0.0.0.0
network 3.3.3.3 0.0.0.0
network 11.1.1.0 0.0.0.255

return

R4:
[R4-ospf-1-area-0.0.0.0]dis this
[V200R003C00]

area 0.0.0.0
network 4.4.4.4 0.0.0.0
network 10.1.1.0 0.0.0.255

return

R5:
[R5-ospf-1-area-0.0.0.0]dis this
[V200R003C00]

area 0.0.0.0
network 5.5.5.5 0.0.0.0
network 10.1.1.0 0.0.0.255

return

6.NBAM(MGRE) 默认接口工作方式为p2p,该工作方式仅允许建立一个邻居关系;导致在MGRE环境中无法建立所有的邻居关系;修改接口方式为广播

R1:
[R1-Tunnel0/0/1]ospf network-type broadcast
[R1-Tunnel0/0/0]ospf network-type broadcast

R2:
[R2-Tunnel0/0/1]ospf network-type broadcast

R3:
[R3-Tunnel0/0/1]ospf network-type broadcast

R4:
[R4-Tunnel0/0/0]ospf network-type broadcast

R5:
[R5-Tunnel0/0/0]ospf network-type broadcast

7.中心站点必须为DR

R2:
[R2]interface Tunnel 0/0/1
[R2-Tunnel0/0/1]ospf dr
[R2-Tunnel0/0/1]ospf dr-priority 0
[R2-Tunnel0/0/1]q
[R2]q
reset ospf pr
reset ospf process
Warning: The OSPF process will be reset. Continue? [Y/N]:y

R3:
[R3-Tunnel0/0/1]ospf dr-priority 0
[R3-Tunnel0/0/1]Q
[R3]Q
reset ospf pr
reset ospf process
Warning: The OSPF process will be reset. Continue? [Y/N]:y

猜你喜欢

转载自blog.csdn.net/weixin_53063133/article/details/113113044