1066 Root of AVL Tree (25 point(s))

1066 Root of AVL Tree (25 point(s))

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-seOf0KRX-1614511463449)(~/31)] [外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-6r8K2ukE-1614511463451)(~/32)]

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88

#include<bits/stdc++.h>
using namespace std;
struct node{
    
    
    int v,height;
    node *lchild,*rchild;
}*root;
int n,v;
int getHeight(node* root){
    
    
    if(root==NULL) return 0;
    return root->height;
}
void updataHeight(node* root){
    
    
    root->height=max(getHeight(root->lchild),getHeight(root->rchild))+1;
}
int getBalanceFactor(node *root){
    
    
    return getHeight(root->lchild)-getHeight(root->rchild);
}
void L(node* &root){
    
    //引用
    node* temp=root->rchild;
    root->rchild=temp->lchild;
    temp->lchild=root;
    updataHeight(root);
    updataHeight(temp);
    root=temp;
}
void R(node* &root){
    
    //引用
    node* temp=root->lchild;
    root->lchild=temp->rchild;
    temp->rchild=root;
    updataHeight(root);
    updataHeight(temp);
    root=temp;
}
void insert(node* &root,int v){
    
    //引用
    if(root==NULL){
    
    
        root=new node;
        root->v=v;
        root->height=1;
        root->lchild=root->rchild=NULL;
        return;
    }
    if(v<root->v){
    
    
        insert(root->lchild,v);
        updataHeight(root);
        if(getBalanceFactor(root)==2){
    
    
            if(getBalanceFactor(root->lchild)==1)//LL
                R(root);
            else if(getBalanceFactor(root->lchild)==-1){
    
    //LR
                L(root->lchild);
                R(root);
            }
        }
    }else{
    
    
        insert(root->rchild,v);
        updataHeight(root);
        if(getBalanceFactor(root)==-2){
    
    
            if(getBalanceFactor(root->rchild)==-1)//RR
                L(root);
            else if(getBalanceFactor(root->rchild)==1){
    
    //RL
                R(root->rchild);
                L(root);
            }
        }
    }
}
int main(){
    
    
    scanf("%d",&n);
    for(int i=0;i<n;++i){
    
    
        scanf("%d",&v);
        insert(root,v);
    }
    printf("%d\n",root->v);
}

猜你喜欢

转载自blog.csdn.net/weixin_44970602/article/details/114237888