Cow Contest——floyd确定两点之间关系

第一眼看到这题,我原本是想用双端拓扑排序做的,后来发现不对,因为一段的拓扑排序会影响另一端的结果。
于是改用floyd算法,求得两点之间关系,和n-1个点保持关系的就是确定好排名的点。

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow
A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤
B ≤ N; A ≠ B), then cow A will always beat cow
B.
Farmer John is trying to rank the cows by skill level. Given a list the results of
M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.


Input 

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer,
A, is the winner) of a single round of competition: A and B

Output 

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input 
5 5
4 3
4 2
3 2
1 2
2 5

Sample Output 
2
*********************************************************************
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

int n,m;
int dis[110][110];

int main()
{
    
    
	
	cin>>n>>m;
	for(int i=1;i<=m;i++)
	{
    
    
		int u,v;
		cin>>u>>v;
		dis[u][v] = 1;
		dis[v][u] = -1;
	}
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
			{
    
    
				if(dis[i][k] ==dis[k][j]&&dis[i][k]!=0)
					dis[i][j] = dis[i][k];
			}
	int ans = 0;
	for(int i=1;i<=n;i++)
	{
    
    
		int sum = 0;
		for(int j=1;j<=n;j++)
		{
    
    
			if(i==j)continue;
			if(dis[i][j]!=0)sum++;
		}	
		if(sum==n-1)ans++;	
	}
	printf("%d\n",ans);
}

猜你喜欢

转载自blog.csdn.net/naiue/article/details/107548471